From: Nicolas Thill <nico@openwrt.org>
Date: Fri, 22 Jul 2005 22:57:30 +0000 (+0000)
Subject: add an initscript
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=15f3d986a37ebf9b83e0a8fdb118ecc4256585c4;p=openwrt%2Fstaging%2Fdedeckeh.git

add an initscript

SVN-Revision: 1535
---

diff --git a/openwrt/package/portmap/Makefile b/openwrt/package/portmap/Makefile
index 5dd79f9a50..20bba966dc 100644
--- a/openwrt/package/portmap/Makefile
+++ b/openwrt/package/portmap/Makefile
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=portmap
 PKG_VERSION:=5beta
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=781e16ed4487c4caa082c6fef09ead4f
 
 # space separated list or special @SF for sourceforge projects
@@ -31,6 +31,9 @@ $(PKG_BUILD_DIR)/.built:
 	touch $@
 
 $(IPKG_PORTMAP):
+	install -d -m0755 $(IDIR_PORTMAP)/etc/init.d 
+	install -m0755 ./files/portmap.init $(IDIR_PORTMAP)/etc/init.d/portmap
+	ln -sf portmap $(IDIR_PORTMAP)/etc/init.d/S59portmap
 	install -d -m0755 $(IDIR_PORTMAP)/usr/sbin 
 	install -m0755 $(PKG_BUILD_DIR)/portmap $(IDIR_PORTMAP)/usr/sbin/
 	$(RSTRIP) $(IDIR_PORTMAP)