From: Jo-Philipp Wich <jow@openwrt.org>
Date: Fri, 24 Oct 2014 09:24:45 +0000 (+0000)
Subject: linux: add kmod-i2c-piix4
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=16e2c7ab80e7e4ff29ac88df9e7edaa70f7dc991;p=openwrt%2Fstaging%2Fansuel.git

linux: add kmod-i2c-piix4

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>

SVN-Revision: 43040
---

diff --git a/package/kernel/linux/modules/i2c.mk b/package/kernel/linux/modules/i2c.mk
index c0f9f813ec..51c6f59753 100644
--- a/package/kernel/linux/modules/i2c.mk
+++ b/package/kernel/linux/modules/i2c.mk
@@ -170,6 +170,28 @@ endef
 
 $(eval $(call KernelPackage,i2c-tiny-usb))
 
+
+I2C_PIIX4_MODULES:= \
+  CONFIG_I2C_PIIX4:drivers/i2c/busses/i2c-piix4
+
+define KernelPackage/i2c-piix4
+  $(call i2c_defaults,$(I2C_PIIX4_MODULES),59)
+  TITLE:=Intel PIIX4 and compatible I2C interfaces
+  DEPENDS:=@PCI_SUPPORT @(x86||x86_64) kmod-i2c-core
+endef
+
+define KernelPackage/i2c-piix4/description
+ Support for the Intel PIIX4 family of mainboard I2C interfaces,
+ specifically Intel PIIX4, Intel 440MX, ATI IXP200, ATI IXP300,
+ ATI IXP400, ATI SB600, ATI SB700/SP5100, ATI SB800, AMD Hudson-2,
+ AMD ML, AMD CZ, Serverworks OSB4, Serverworks CSB5,
+ Serverworks CSB6, Serverworks HT-1000, Serverworks HT-1100 and
+ SMSC Victory66.
+endef
+
+$(eval $(call KernelPackage,i2c-piix4))
+
+
 I2C_MUX_MODULES:= \
   CONFIG_I2C_MUX:drivers/i2c/i2c-mux