From: Paul Spooren <mail@aparcar.org>
Date: Fri, 1 Oct 2021 04:26:14 +0000 (-1000)
Subject: prereq-build: revert "fix `which` detection on Fedora"
X-Git-Tag: v22.03.0-rc1~1655
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=16e83a7491bb038187e918273671894992ae003c;p=openwrt%2Fopenwrt.git

prereq-build: revert "fix `which` detection on Fedora"

This reverts commit fca5ad55d292f8e481406123d0e95b3c85d39733.

Causes problems on MacOS host systems.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---

diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 750d334716..9242407b18 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -186,7 +186,7 @@ $(eval $(call SetupHostCommand,rsync,Please install 'rsync', \
 	rsync --version </dev/null))
 
 $(eval $(call SetupHostCommand,which,Please install 'which', \
-	env which which | grep which))
+	which which | grep which))
 
 $(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
 	mkdir -p $(dir $@)