From: Nicolas Thill <nico@openwrt.org>
Date: Thu, 11 Aug 2005 03:08:46 +0000 (+0000)
Subject: Add dosfstools package
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=1852c92c889f5f64b5377cc4b82f4226cd922ff2;p=openwrt%2Fstaging%2Fdedeckeh.git

Add dosfstools package

SVN-Revision: 1608
---

diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index 476fb285e7..4ac95504f6 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -157,9 +157,10 @@ source "package/usbutils/Config.in"  # lsusb
 source "package/strace/Config.in"
 
 # what are we going to do with both of you
-comment "Kernel related ---"
-source "package/fuse/Config.in"  # kmod-fuse
-source "package/shfs/Config.in"  # kmod-shfs
+comment "FileSystems related ---"
+source "package/dosfstools/Config.in"
+source "package/fuse/Config.in"
+source "package/shfs/Config.in"
 
 comment "Bluetooth related"
 source "package/bluez-libs/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 7cfdd021a7..ceb7b72e1e 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -23,6 +23,7 @@ package-$(BR2_PACKAGE_CYRUS_SASL) += cyrus-sasl
 package-$(BR2_PACKAGE_DHCP) += dhcp
 package-$(BR2_PACKAGE_DHCP_FORWARDER) += dhcp-forwarder
 package-$(BR2_PACKAGE_DNSMASQ) += dnsmasq
+package-$(BR2_PACKAGE_DOSFSTOOLS) += dosfstools
 package-$(BR2_PACKAGE_DROPBEAR) += dropbear
 package-$(BR2_PACKAGE_DSNIFF) += dsniff
 package-$(BR2_PACKAGE_EBTABLES) += ebtables
diff --git a/openwrt/package/dosfstools/Config.in b/openwrt/package/dosfstools/Config.in
new file mode 100644
index 0000000000..9f731e7120
--- /dev/null
+++ b/openwrt/package/dosfstools/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_DOSFSTOOLS
+	tristate "dosfstools - Utilities to create and check MS-DOS FAT filesystems"
+#	default m if CONFIG_DEVEL
+	default n
+	help
+	  Utilities to create and check MS-DOS FAT filesystems.
+	  
+	  ftp://ftp.uni-erlangen.de:/pub/Linux/LOCAL/dosfstools/
+	  
+
diff --git a/openwrt/package/dosfstools/Makefile b/openwrt/package/dosfstools/Makefile
new file mode 100644
index 0000000000..2ac745a1dd
--- /dev/null
+++ b/openwrt/package/dosfstools/Makefile
@@ -0,0 +1,44 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dosfstools
+PKG_VERSION:=2.11
+PKG_RELEASE:=1
+PKG_MD5SUM:=407d405ade410f7597d364ab5dc8c9f6
+
+PKG_SOURCE_URL:=ftp://ftp.uni-erlangen.de/pub/Linux/LOCAL/dosfstools/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).src.tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+BR2_PACKAGE_DOSFSTOOLS=m
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,DOSFSTOOLS,dosfstools,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+	touch $@
+
+$(PKG_BUILD_DIR)/.built:
+	rm -rf $(PKG_INSTALL_DIR)
+	mkdir -p $(PKG_INSTALL_DIR)
+	$(MAKE) -C $(PKG_BUILD_DIR) \
+		$(TARGET_CONFIGURE_OPTS) \
+		OPTFLAGS="$(TARGET_CFLAGS) -D_FILE_OFFSET_BITS=64" \
+		PREFIX="$(PKG_INSTALL_DIR)" \
+		all install
+	touch $@
+
+$(IPKG_DOSFSTOOLS):
+	install -d -m0755 $(IDIR_DOSFSTOOLS)/sbin
+	cp -fpR $(PKG_INSTALL_DIR)/sbin/dosfsck $(IDIR_DOSFSTOOLS)/sbin/
+	cp -fpR $(PKG_INSTALL_DIR)/sbin/fsck.{msdos,vfat} $(IDIR_DOSFSTOOLS)/sbin/
+	cp -fpR $(PKG_INSTALL_DIR)/sbin/mkdosfs $(IDIR_DOSFSTOOLS)/sbin/
+	cp -fpR $(PKG_INSTALL_DIR)/sbin/mkfs.{msdos,vfat} $(IDIR_DOSFSTOOLS)/sbin/
+	$(RSTRIP) $(IDIR_DOSFSTOOLS)
+	$(IPKG_BUILD) $(IDIR_DOSFSTOOLS) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/dosfstools/ipkg/dosfstools.control b/openwrt/package/dosfstools/ipkg/dosfstools.control
new file mode 100644
index 0000000000..d7f8ed92b2
--- /dev/null
+++ b/openwrt/package/dosfstools/ipkg/dosfstools.control
@@ -0,0 +1,6 @@
+Package: dosfstools
+Priority: optional
+Section: admin
+Maintainer: OpenWrt Developers <bugs@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/dosfstools/
+Description: Utilities to create and check MS-DOS FAT filesystems