From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Sun, 5 Aug 2012 23:43:36 +0000 (+0000)
Subject: mac80211: remove header files used to share struct with platform code.
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=19a8508046b3286aef58f6b534360d3ebec1d1fd;p=openwrt%2Fstaging%2Fdedeckeh.git

mac80211: remove header files used to share struct with platform code.

The structs defined in these header files should be the same as the
structes used by the platform code otherwise it will cause strange
runtime errors. By removing them from compat-wireless we will get a
compile error instead of a runtime error if they are out of sync.

SVN-Revision: 33006
---

diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index a6738af768..f1a797e607 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -1329,7 +1329,13 @@ define Build/Prepare
 	$(TAR) -C $(PKG_BUILD_DIR) -xjf $(DL_DIR)/$(PKG_LINUX_FIRMWARE_SOURCE)
 	rm -rf $(PKG_BUILD_DIR)/include/linux/ssb
 	rm -rf $(PKG_BUILD_DIR)/include/linux/bcma
+	rm -rf $(PKG_BUILD_DIR)/include/net/bluetooth/
 	rm -f $(PKG_BUILD_DIR)/include/linux/eeprom_93cx6.h
+	rm -f $(PKG_BUILD_DIR)/include/linux/ath9k_platform.h
+	rm -f $(PKG_BUILD_DIR)/include/linux/ath5k_platform.h
+	rm -f $(PKG_BUILD_DIR)/include/linux/rt2x00_platform.h
+	rm -f $(PKG_BUILD_DIR)/include/linux/wl12xx.h
+	rm -f $(PKG_BUILD_DIR)/include/linux/spi/libertas_spi.h
 	rm -f $(PKG_BUILD_DIR)/include/net/ieee80211.h
 	echo 'compat-wireless-$(PKG_VERSION)-$(PKG_RELEASE)-$(REVISION)' > $(PKG_BUILD_DIR)/compat_version
 	$(CP) ./files/regdb.txt $(PKG_BUILD_DIR)/net/wireless/db.txt