From: Florian Fainelli <florian@openwrt.org>
Date: Mon, 3 Sep 2012 20:25:46 +0000 (+0000)
Subject: pad squashfs image
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=19cbe80501688d31fb90c41c06e274e27fb449d1;p=openwrt%2Fstaging%2Fdedeckeh.git

pad squashfs image

SVN-Revision: 33314
---

diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 5545e042e6..7386db0766 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -45,6 +45,10 @@ define Image/BuildKernel
 	$(call Image/Build/Initramfs)
 endef
 
+define Image/Build/squashfs
+	$(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR)/root.squashfs 128
+endef
+
 define Image/Build
 	$(call Image/Build/$(1))
 	dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync