From: Felix Fietkau <nbd@nbd.name>
Date: Thu, 22 Feb 2018 08:29:54 +0000 (+0100)
Subject: grub2: disable building platform code for target utility
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=1b13cbc15b2922d6b79c1e481b252934591326bd;p=openwrt%2Fstaging%2Fnbd.git

grub2: disable building platform code for target utility

It is not used and it was causing a build error with GCC 7.3

Signed-off-by: Felix Fietkau <nbd@nbd.name>
---

diff --git a/package/boot/grub2/Makefile b/package/boot/grub2/Makefile
index 8cfc0dcff9..b2ae171569 100644
--- a/package/boot/grub2/Makefile
+++ b/package/boot/grub2/Makefile
@@ -60,7 +60,8 @@ CONFIGURE_ARGS += \
 	--disable-nls \
 	--disable-device-mapper \
 	--disable-libzfs \
-	--disable-grub-mkfont
+	--disable-grub-mkfont \
+	--with-platform=none
 
 HOST_CONFIGURE_VARS += \
 	grub_build_mkfont_excuse="don't want fonts"