From: Petr Štetiar <ynezz@true.cz>
Date: Fri, 9 Nov 2018 11:09:29 +0000 (+0100)
Subject: Revert "iptables: fix dependency for libip6tc on IPV6"
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=1b4b942bcef8638a040788ab9ae94c66e38fd960;p=openwrt%2Fstaging%2Fansuel.git

Revert "iptables: fix dependency for libip6tc on IPV6"

This patch reverts commit 2dc1f54b1205094e7c6036cae6275d2c326bad3e as it
breaks the build for me on x86-64 if I've IPV6 support disabled. Same config
builds fine on `openwrt-18.06` branch at 55d078b2.

  $ grep IPV6 .config

  # CONFIG_KERNEL_IPV6 is not set
  # CONFIG_IPV6 is not set

Build errors out on:

  Package libiptc is missing dependencies for the following libraries:
  libip6tc.so.0

Looking at iptables-1.6.2/libiptc/Makefile.am:

  libiptc_la_LIBADD   = libip4tc.la libip6tc.la

and to iptables-1.6.2/libiptc/libiptc.pc.in:

  Requires:	libip4tc libip6tc

It seems that libiptc needs v4/v6 libs, so v6 isn't optional.

Cc: Rosy Song <rosysong@rosinson.com>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
---

diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 2beaa7135e..4c5a581268 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -492,7 +492,7 @@ define Package/libiptc
 $(call Package/iptables/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libip4tc +IPV6:libip6tc +libxtables
+  DEPENDS:=+libip4tc +libip6tc +libxtables
   ABI_VERSION:=$(PKG_VERSION)
   TITLE:=IPv4/IPv6 firewall - shared libiptc library (compatibility stub)
 endef
@@ -512,7 +512,7 @@ $(call Package/iptables/Default)
   CATEGORY:=Libraries
   TITLE:=IPv6 firewall - shared libiptc library
   ABI_VERSION:=$(PKG_VERSION)
-  DEPENDS:=@IPV6 +libxtables
+  DEPENDS:=+libxtables
 endef
 
 define Package/libxtables