From: Zoltan Herpai <wigyori@uid0.hu>
Date: Sat, 15 Aug 2015 15:10:14 +0000 (+0000)
Subject: sunxi: respect CONFIG_TARGET_IMAGES_GZIP
X-Git-Tag: reboot~2290
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=1c66ebcd2db1e85590b11e0abc750eef25363328;p=openwrt%2Fopenwrt.git

sunxi: respect CONFIG_TARGET_IMAGES_GZIP

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>

SVN-Revision: 46608
---

diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 10d2200aa3..5a5c98a7c0 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -45,6 +45,10 @@ define Image/Build/SDCard
 		$(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
 		$(CONFIG_TARGET_ROOTFS_PARTSIZE) \
 		$(KDIR)/uboot-sunxi-$(PROFILE)-u-boot-with-spl.bin
+
+  ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
+	gzip -f9n $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-sdcard-vfat-$(1).img
+  endif
 endef
 
 define Image/Build/Profile/A10-OLinuXino-Lime