From: Jo-Philipp Wich <jow@openwrt.org>
Date: Mon, 24 Sep 2012 18:26:48 +0000 (+0000)
Subject: version.mk: ensure that %S is always populated with a subtarget identifier, fallback... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=1cd6237979dafaa5d1e7ec9502dc022015bbc795;p=openwrt%2Fstaging%2Fdedeckeh.git

version.mk: ensure that %S is always populated with a subtarget identifier, fallback to "generic" if no subtarget exists

SVN-Revision: 33534
---

diff --git a/include/version.mk b/include/version.mk
index 4687dcc2e0..2bf709e56e 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -40,4 +40,4 @@ VERSION_SED:=$(SED) 's,%U,$(VERSION_REPO),g' \
 	-e 's,%d,\L$(subst $(space),_,$(VERSION_DIST)),g' \
 	-e 's,%R,$(REVISION),g' \
 	-e 's,%T,$(BOARD),g' \
-	-e 's,%S,$(BOARD)$(if $(SUBTARGET),/$(SUBTARGET)),g' \
+	-e 's,%S,$(BOARD)/$(if $(SUBTARGET),$(SUBTARGET),generic),g' \