From: John Crispin <john@openwrt.org>
Date: Thu, 9 Apr 2015 10:33:16 +0000 (+0000)
Subject: kernel: add rtl8723au driver (staging)
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=1d345d3e6ba5c14370ee3d8287f98776073e8591;p=openwrt%2Fstaging%2Fsvanheule.git

kernel: add rtl8723au driver (staging)

- move config symbol to separate package (Why was it there in the first place?)
- 8723au might be used in some USB sticks or on some sunxi boards

compile tested only

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>

SVN-Revision: 45336
---

diff --git a/package/kernel/linux/modules/wireless.mk b/package/kernel/linux/modules/wireless.mk
index 30ba0a87c2..086a401ecc 100644
--- a/package/kernel/linux/modules/wireless.mk
+++ b/package/kernel/linux/modules/wireless.mk
@@ -114,7 +114,6 @@ define KernelPackage/net-rtl8188eu
   KCONFIG:=\
 	CONFIG_STAGING=y \
 	CONFIG_R8188EU \
-	CONFIG_R8723AU \
 	CONFIG_88EU_AP_MODE=y \
 	CONFIG_88EU_P2P=n
   FILES:=$(LINUX_DIR)/drivers/staging/rtl8188eu/r8188eu.ko
@@ -127,6 +126,27 @@ endef
 
 $(eval $(call KernelPackage,net-rtl8188eu))
 
+
+define KernelPackage/net-rtl8723au
+  SUBMENU:=$(WIRELESS_MENU)
+  TITLE:=RTL8723AU support (staging)
+  DEPENDS:=@!LINUX_3_10 @USB_SUPPORT +@DRIVER_WEXT_SUPPORT +r8188eu-firmware +kmod-usb-core
+  KCONFIG:=\
+        CONFIG_STAGING=y \
+        CONFIG_R8723AU \
+        CONFIG_8723AU_AP_MODE=y \
+        CONFIG_8723AU_BT_COEXIST=y
+  FILES:=$(LINUX_DIR)/drivers/staging/rtl8723au/r8723au.ko
+  AUTOLOAD:=$(call AutoProbe,r8723au)
+endef
+
+define KernelPackage/net-rtl8723au/description
+ Kernel modules for RealTek RTL8723AU support
+endef
+
+$(eval $(call KernelPackage,net-rtl8723au))
+
+
 define KernelPackage/net-rtl8192su
   SUBMENU:=$(WIRELESS_MENU)
   TITLE:=RTL8192SU support (staging)