From: Felix Fietkau <nbd@openwrt.org>
Date: Wed, 22 Oct 2014 08:57:20 +0000 (+0000)
Subject: rules.mk: reduce shexport to one line to allow it to be put in a target context
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=20a3814a9cd2d5f73518f65101c3015879e0a92a;p=openwrt%2Fstaging%2Fansuel.git

rules.mk: reduce shexport to one line to allow it to be put in a target context

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 43018
---

diff --git a/rules.mk b/rules.mk
index 8844a47a1f..0822979012 100644
--- a/rules.mk
+++ b/rules.mk
@@ -278,8 +278,7 @@ V_$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
 endef
 
 define shexport
-$(call shvar,$(1))=$$(call $(1))
-export $(call shvar,$(1))
+export $(call shvar,$(1))=$$(call $(1))
 endef
 
 define include_mk