From: Vasilis Tsiligiannis <acinonyx@openwrt.gr>
Date: Mon, 23 Jul 2012 19:17:05 +0000 (+0000)
Subject: Revert "[package] kernel/modules: dont only change loading order on IPSEC*-m, propaga... 
X-Git-Tag: reboot~13339
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=20eddc1e92d0a41fe5c6aae40eaf30f240f5f626;p=openwrt%2Fstaging%2Fblogic.git

Revert "[package] kernel/modules: dont only change loading order on IPSEC*-m, propagate this to documentation too"

Preserve alphabetical order on KCONFIG and description for consistency with other module packages

This reverts commit r32775.

SVN-Revision: 32791
---

diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 5d78027efa13..b4e2a425a00f 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -275,11 +275,11 @@ define KernelPackage/ipsec4
   KCONFIG:= \
 	CONFIG_INET_AH \
 	CONFIG_INET_ESP \
+	CONFIG_INET_IPCOMP \
 	CONFIG_INET_XFRM_MODE_BEET \
 	CONFIG_INET_XFRM_MODE_TRANSPORT \
 	CONFIG_INET_XFRM_MODE_TUNNEL \
-	CONFIG_INET_XFRM_TUNNEL \
-	CONFIG_INET_IPCOMP
+	CONFIG_INET_XFRM_TUNNEL
   FILES:=$(foreach mod,$(IPSEC4-m),$(LINUX_DIR)/net/$(mod).ko)
   AUTOLOAD:=$(call AutoLoad,32,$(notdir $(IPSEC4-m)))
 endef
@@ -289,11 +289,11 @@ define KernelPackage/ipsec4/description
  Includes:
  - ah4
  - esp4
+ - ipcomp4
  - xfrm4_mode_beet
  - xfrm4_mode_transport
  - xfrm4_mode_tunnel
  - xfrm4_tunnel
- - ipcomp
 endef
 
 $(eval $(call KernelPackage,ipsec4))
@@ -315,11 +315,11 @@ define KernelPackage/ipsec6
   KCONFIG:= \
 	CONFIG_INET6_AH \
 	CONFIG_INET6_ESP \
+	CONFIG_INET6_IPCOMP \
 	CONFIG_INET6_XFRM_MODE_BEET \
 	CONFIG_INET6_XFRM_MODE_TRANSPORT \
 	CONFIG_INET6_XFRM_MODE_TUNNEL \
-	CONFIG_INET6_XFRM_TUNNEL \
-	CONFIG_INET6_IPCOMP
+	CONFIG_INET6_XFRM_TUNNEL
   FILES:=$(foreach mod,$(IPSEC6-m),$(LINUX_DIR)/net/$(mod).ko)
   AUTOLOAD:=$(call AutoLoad,32,$(notdir $(IPSEC6-m)))
 endef
@@ -329,11 +329,11 @@ define KernelPackage/ipsec6/description
  Includes:
  - ah6
  - esp6
+ - ipcomp6
  - xfrm6_mode_beet
  - xfrm6_mode_transport
  - xfrm6_mode_tunnel
  - xfrm6_tunnel
- - ipcomp6
 endef
 
 $(eval $(call KernelPackage,ipsec6))