From: Jo-Philipp Wich <jow@openwrt.org>
Date: Thu, 27 Oct 2011 00:23:16 +0000 (+0000)
Subject: busybox: disable rdate, enable ntpd by default
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=219d772ce89181ba4a55f842e106075fb7fad568;p=openwrt%2Fstaging%2Faparcar.git

busybox: disable rdate, enable ntpd by default

SVN-Revision: 28613
---

diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index f2894017fb..9e991c3625 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.19.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/busybox/config/networking/Config.in b/package/busybox/config/networking/Config.in
index ca9815757d..a70dd07ac2 100644
--- a/package/busybox/config/networking/Config.in
+++ b/package/busybox/config/networking/Config.in
@@ -742,14 +742,14 @@ config BUSYBOX_CONFIG_NSLOOKUP
 
 config BUSYBOX_CONFIG_NTPD
 	bool "ntpd"
-	default n
+	default y
 	select BUSYBOX_CONFIG_PLATFORM_LINUX
 	help
 	  The NTP client/server daemon.
 
 config BUSYBOX_CONFIG_FEATURE_NTPD_SERVER
 	bool "Make ntpd usable as a NTP server"
-	default n
+	default y
 	depends on BUSYBOX_CONFIG_NTPD
 	help
 	  Make ntpd usable as a NTP server. If you disable this option
diff --git a/package/busybox/config/util-linux/Config.in b/package/busybox/config/util-linux/Config.in
index 56e8035865..14d4777bea 100644
--- a/package/busybox/config/util-linux/Config.in
+++ b/package/busybox/config/util-linux/Config.in
@@ -600,7 +600,7 @@ config BUSYBOX_CONFIG_PIVOT_ROOT
 
 config BUSYBOX_CONFIG_RDATE
 	bool "rdate"
-	default y
+	default n
 	help
 	  The rdate utility allows you to synchronize the date and time of your
 	  system clock with the date and time of a remote networked system using