From: Jan-Niklas Burfeind <git@aiyionpri.me>
Date: Sat, 21 May 2022 15:17:34 +0000 (+0200)
Subject: ath79: NanoBeam M5 fix target_devices
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=21a3ce97d571ef28a25754549503bab61a79faf2;p=openwrt%2Fstaging%2Fjogo.git

ath79: NanoBeam M5 fix target_devices

Update the name of for the Ubiquiti NanoBeam M5 to match the
auto-generated one at runtime. Otherwise sysupgrade complains about
mismatching device names.

This also required renaming the DTS.

Signed-off-by: Jan-Niklas Burfeind <git@aiyionpri.me>
---

diff --git a/target/linux/ath79/dts/ar9342_ubnt_nanobeam-m5-xw.dts b/target/linux/ath79/dts/ar9342_ubnt_nanobeam-m5-xw.dts
new file mode 100644
index 0000000000..86a5e3a751
--- /dev/null
+++ b/target/linux/ath79/dts/ar9342_ubnt_nanobeam-m5-xw.dts
@@ -0,0 +1,26 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9342_ubnt_xw.dtsi"
+
+/ {
+	compatible = "ubnt,nanobeam-m5-xw", "ubnt,xw", "qca,ar9342";
+	model = "Ubiquiti NanoBeam M5 (XW)";
+};
+
+&mdio0 {
+	status = "okay";
+
+	phy-mask = <0x1>;
+
+	phy1: ethernet-phy@1 {
+		reg = <1>;
+		phy-mode = "mii";
+		reset-gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
+	};
+};
+
+&eth0 {
+	status = "okay";
+
+	phy-handle = <&phy1>;
+};
diff --git a/target/linux/ath79/dts/ar9342_ubnt_nanobeam-m5.dts b/target/linux/ath79/dts/ar9342_ubnt_nanobeam-m5.dts
deleted file mode 100644
index 86a5e3a751..0000000000
--- a/target/linux/ath79/dts/ar9342_ubnt_nanobeam-m5.dts
+++ /dev/null
@@ -1,26 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "ar9342_ubnt_xw.dtsi"
-
-/ {
-	compatible = "ubnt,nanobeam-m5-xw", "ubnt,xw", "qca,ar9342";
-	model = "Ubiquiti NanoBeam M5 (XW)";
-};
-
-&mdio0 {
-	status = "okay";
-
-	phy-mask = <0x1>;
-
-	phy1: ethernet-phy@1 {
-		reg = <1>;
-		phy-mode = "mii";
-		reset-gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
-	};
-};
-
-&eth0 {
-	status = "okay";
-
-	phy-handle = <&phy1>;
-};
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 3713f538f1..2381d92567 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -255,13 +255,13 @@ define Device/ubnt_nanobeam-ac-xc
 endef
 TARGET_DEVICES += ubnt_nanobeam-ac-xc
 
-define Device/ubnt_nanobeam-m5
+define Device/ubnt_nanobeam-m5-xw
   $(Device/ubnt-xw)
   DEVICE_MODEL := NanoBeam M5
   DEVICE_PACKAGES += rssileds
   SUPPORTED_DEVICES += loco-m-xw
 endef
-TARGET_DEVICES += ubnt_nanobeam-m5
+TARGET_DEVICES += ubnt_nanobeam-m5-xw
 
 define Device/ubnt_nanobridge-m
   $(Device/ubnt-xm)