From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 2 Nov 2009 00:47:21 +0000 (+0000)
Subject: add cloog and ppl to the tools build for the graphite framework in gcc 4.4
X-Git-Tag: reboot~21996
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=22523c204a075bb7740ca27801e25dee3722ba1d;p=openwrt%2Fstaging%2Fblogic.git

add cloog and ppl to the tools build for the graphite framework in gcc 4.4

SVN-Revision: 18264
---

diff --git a/tools/Makefile b/tools/Makefile
index 0d91b1f95627..8a5f36c2846d 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -19,6 +19,11 @@ tools-$(CONFIG_CCACHE) += ccache
 tools-$(CONFIG_powerpc) += dtc
 tools-dep += lzma
 
+ifdef CONFIG_GCC_VERSION_4_4
+  tools-y += ppl cloog
+  $(curdir)/cloog/compile := $(curdir)/ppl/install
+endif
+
 # builddir dependencies
 $(curdir)/pkg-config/compile := $(curdir)/sed/install
 $(curdir)/squashfs/compile := $(curdir)/lzma-old/install
diff --git a/tools/cloog/Makefile b/tools/cloog/Makefile
new file mode 100644
index 000000000000..e2043b1f7434
--- /dev/null
+++ b/tools/cloog/Makefile
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cloog-ppl
+PKG_VERSION:=0.15.7
+
+PKG_SOURCE_URL:=ftp://gcc.gnu.org/pub/gcc/infrastructure
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=6455e7875daac5bd885545c71c3f2001
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+ifeq ($(HOST_OS),Darwin)
+  GNU_HOST_NAME:=
+  HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
+endif
+
+HOST_CONFIGURE_VARS += \
+	LIBS=-lstdc++
+
+HOST_CONFIGURE_ARGS += \
+	--enable-static \
+	--disable-shared \
+	--with-ppl=$(BUILD_DIR_HOST)
+
+define Host/Configure
+	(cd $(HOST_BUILD_DIR)/$(3); \
+		$(HOST_CONFIGURE_CMD) \
+		$(HOST_CONFIGURE_VARS) \
+		$(HOST_CONFIGURE_ARGS); \
+	)
+endef
+
+
+$(eval $(call HostBuild))
diff --git a/tools/ppl/Makefile b/tools/ppl/Makefile
new file mode 100644
index 000000000000..c9c09c512592
--- /dev/null
+++ b/tools/ppl/Makefile
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ppl
+PKG_VERSION:=0.10.2
+
+PKG_SOURCE_URL:=ftp://gcc.gnu.org/pub/gcc/infrastructure
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=e7dd265afdeaea81f7e87a72b182d875
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+ifeq ($(HOST_OS),Darwin)
+  GNU_HOST_NAME:=
+  HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
+endif
+
+HOST_CONFIGURE_ARGS += \
+	--enable-static \
+	--disable-shared
+
+define Host/Configure
+	(cd $(HOST_BUILD_DIR)/$(3); \
+		$(HOST_CONFIGURE_CMD) \
+		$(HOST_CONFIGURE_VARS) \
+		$(HOST_CONFIGURE_ARGS); \
+	)
+endef
+
+
+$(eval $(call HostBuild))