From: Gabor Juhos <juhosg@openwrt.org>
Date: Thu, 23 Aug 2012 11:52:18 +0000 (+0000)
Subject: ar71xx: image: add a few helper functions
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=2379e6f2a302e90f21a69bd7a101d467a774d3bb;p=openwrt%2Fstaging%2Fdedeckeh.git

ar71xx: image: add a few helper functions

These functions will be used to simplify the Makefile.

SVN-Revision: 33237
---

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index d885acb168..1f00ba063d 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -23,6 +23,26 @@ define factoryname
 $(call imgname,$(1),$(2))-factory.bin
 endef
 
+COMMA:=,
+
+define mkcmdline
+$(if $(1),board=$(1) )$(if $(2),console=$(2)$(COMMA)$(3))
+endef
+
+define SingleProfile
+  define Image/Build/Profile/$(3)
+	$$(call Image/Build/Template/$(2)/$$(1),$(1),$(4),$$(call mkcmdline,$(5),$(6),$(7)),$(8),$(9),$(10),$(11),$(12))
+  endef
+endef
+
+define MultiProfile
+  define Image/Build/Profile/$(1)
+	$(foreach p,$(2),
+		$$(call Image/Build/Profile/$p,$$(1))
+	)
+  endef
+endef
+
 LOADER_MAKE := $(NO_TRACE_MAKE) -C lzma-loader KDIR=$(KDIR)
 
 KDIR_TMP:=$(KDIR)/tmp