From: Daniel Golle <daniel@makrotopia.org>
Date: Sat, 31 Oct 2020 00:06:53 +0000 (+0000)
Subject: libselinux: remove dependency on musl-fts for non-musl builds
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=237f708b3c5f6e4f92c8a892fe2cbb3d22df8e9f;p=openwrt%2Fstaging%2Fjogo.git

libselinux: remove dependency on musl-fts for non-musl builds

Suggested-by: Curtis Deptuck <curtdept@users.noreply.github.com>
Tested-by: Curtis Deptuck <curtdept@users.noreply.github.com>
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
---

diff --git a/package/libs/libselinux/Makefile b/package/libs/libselinux/Makefile
index 20d9225d39..5fe745d004 100644
--- a/package/libs/libselinux/Makefile
+++ b/package/libs/libselinux/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libselinux
 PKG_VERSION:=3.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/20200710
@@ -69,7 +69,7 @@ define Package/libselinux
   $(call Package/libselinux/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libsepol +libpcre +musl-fts
+  DEPENDS:=+libsepol +libpcre +USE_MUSL:musl-fts
 endef
 
 define Package/libselinux/description
@@ -109,8 +109,11 @@ HOST_MAKE_FLAGS += \
 	PREFIX=$(STAGING_DIR_HOSTPKG) \
 	SHLIBDIR=$(STAGING_DIR_HOSTPKG)/lib
 
+ifeq ($(CONFIG_USE_MUSL),y)
+MAKE_FLAGS += FTS_LDLIBS=-lfts
+endif
+
 MAKE_FLAGS += \
-	FTS_LDLIBS=-lfts \
 	SHLIBDIR=/usr/lib \
 	OS=Linux