From: Andy Boyett <agb@openwrt.org>
Date: Fri, 4 Apr 2008 21:48:43 +0000 (+0000)
Subject: Install libuci and headers in staging_dir
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=24c9bbe5f779d6685a21a9de51924cc1dac3fc96;p=openwrt%2Fstaging%2Fdangole.git

Install libuci and headers in staging_dir

SVN-Revision: 10732
---

diff --git a/package/uci/Makefile b/package/uci/Makefile
index 54d01c1589..41430f7e14 100644
--- a/package/uci/Makefile
+++ b/package/uci/Makefile
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -73,6 +73,13 @@ define Package/uci-sh/install
 	$(CP) ./files/uci-sh/* $(1)/
 endef
 
+define Build/InstallDev
+	$(INSTALL_DIR) $(1)/usr/include
+	$(CP) $(PKG_BUILD_DIR)/uci{,_config}.h $(1)/usr/include
+	$(INSTALL_DIR) $(1)/usr/lib
+	$(CP) $(PKG_BUILD_DIR)/libuci.so* $(1)/usr/lib
+endef
+
 $(eval $(call BuildPackage,uci))
 $(eval $(call BuildPackage,libuci))
 $(eval $(call BuildPackage,uci-sh))