From: Jo-Philipp Wich <jow@openwrt.org>
Date: Fri, 28 May 2010 00:27:01 +0000 (+0000)
Subject: add 6in4 - support for static IPv6-in-IPv4 tunnels through /etc/config/network
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=278589f5d70dbe790d31cb5015d3723daa739941;p=openwrt%2Fstaging%2Fynezz.git

add 6in4 - support for static IPv6-in-IPv4 tunnels through /etc/config/network

SVN-Revision: 21589
---

diff --git a/package/6in4/Makefile b/package/6in4/Makefile
new file mode 100644
index 0000000000..725c283ded
--- /dev/null
+++ b/package/6in4/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=6in4
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/6in4
+  SECTION:=ipv6
+  CATEGORY:=IPv6
+  DEPENDS:=+ip +kmod-ipv6 +kmod-sit
+  TITLE:=IPv6-in-IPv4 configuration support
+  PKGARCH:=all
+endef
+
+define Package/6in4/description
+Provides support for 6in4 tunnels in /etc/config/network.
+Refer to http://wiki.openwrt.org/doc/uci/network for
+configuration details.
+endef
+
+define Build/Compile
+endef
+
+define Build/Configure
+endef
+
+define Package/6in4/install
+	$(INSTALL_DIR) $(1)/lib/network
+	$(INSTALL_DATA) ./files/6in4.sh $(1)/lib/network/6in4.sh
+endef
+
+$(eval $(call BuildPackage,6in4))
diff --git a/package/6in4/files/6in4.sh b/package/6in4/files/6in4.sh
new file mode 100755
index 0000000000..68a00edd86
--- /dev/null
+++ b/package/6in4/files/6in4.sh
@@ -0,0 +1,79 @@
+# 6in4.sh - IPv6-in-IPv4 tunnel backend
+# Copyright (c) 2010 OpenWrt.org
+
+# Hook into scan_interfaces() to synthesize a .device option
+# This is needed for /sbin/ifup to properly dispatch control
+# to setup_interface_6in4() even if no .ifname is set in
+# the configuration.
+scan_6in4() {
+	config_set "$1" device "6in4-$1"
+}
+
+coldplug_interface_6in4() {
+	setup_interface_6in4 "6in4-$1" "$1"
+}
+
+setup_interface_6in4() {
+	local iface="$1"
+	local cfg="$2"
+	local link="6in4-$cfg"
+
+	local local4
+	config_get local4 "$cfg" ipaddr
+
+	local remote4
+	config_get remote4 "$cfg" peeraddr
+
+	local local6
+	config_get local6 "$cfg" ip6addr
+
+	local mtu
+	config_get mtu "$cfg" mtu
+
+	local ttl
+	config_get ttl "$cfg" ttl
+
+	local defaultroute
+	config_get_bool defaultroute "$cfg" defaultroute 1
+
+
+	# creating the tunnel below will trigger a net subsystem event
+	# prevent it from touching or iface by disabling .auto here
+	uci_set_state network "$cfg" ifname $link
+	uci_set_state network "$cfg" auto 0
+
+	ip tunnel add $link mode sit remote $remote4 local $local4 ttl 255
+	ip link set $link up
+	ip link set mtu ${mtu:-1280} dev $link
+	ip tunnel change $link ttl ${ttl:-64}
+	ip addr add $local6 dev $link
+
+	uci_set_state network "$cfg" ip6addr $local6
+
+	[ "$defaultroute" = 1 ] && {
+		ip -6 route add ::/0 dev $link
+		uci_set_state network "$cfg" defaultroute 1
+	}
+
+	env -i ACTION="ifup" INTERFACE="$cfg" DEVICE="$link" PROTO=6in4 /sbin/hotplug-call "iface" &
+}
+
+stop_interface_6in4() {
+	local cfg="$1"
+	local link="6in4-$cfg"
+
+	local local6=$(uci_get_state network "$cfg" ip6addr)
+	local defaultroute=$(uci_get_state network "$cfg" defaultroute)
+
+	grep -qs "^ *$link:" /proc/net/dev && {
+		env -i ACTION="ifdown" INTERFACE="$cfg" DEVICE="$link" PROTO=6in4 /sbin/hotplug-call "iface" &
+
+		[ "$defaultroute" = "1" ] && {
+			ip -6 route del ::/0 dev $link
+		}
+
+		ip addr del $local6 dev $link
+		ip link set $link down
+		ip tunnel del $link
+	}
+}