From: Felix Fietkau <nbd@openwrt.org>
Date: Sat, 7 Nov 2015 12:52:07 +0000 (+0000)
Subject: rules.mk: export STAGING_DIR_HOST to sub-makefiles and shells
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=279c8bee8d6584b68b182f509927f27477ec0a4c;p=openwrt%2Fstaging%2Fnbd.git

rules.mk: export STAGING_DIR_HOST to sub-makefiles and shells

Certains host packages (like quilt) need to know the previously used
install location at run-time. They currently use $STAGING_DIR, which
causes issues on cleaned environment, where $STAGING_DIR doesn't exist
yet.

Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>

SVN-Revision: 47409
---

diff --git a/rules.mk b/rules.mk
index 7710fb4d9d..348b45d6e1 100644
--- a/rules.mk
+++ b/rules.mk
@@ -188,7 +188,7 @@ else
 endif
 
 export PATH:=$(TARGET_PATH)
-export STAGING_DIR
+export STAGING_DIR STAGING_DIR_HOST
 export SH_FUNC:=. $(INCLUDE_DIR)/shell.sh;
 
 PKG_CONFIG:=$(STAGING_DIR_HOST)/bin/pkg-config