From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 16 Jul 2007 06:35:00 +0000 (+0000)
Subject: find: use -follow instead of -L, some systems don't support -L
X-Git-Tag: reboot~28652
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=2809e403d6246076eb3f884c9137a3269a027e39;p=openwrt%2Fstaging%2Fpepe2k.git

find: use -follow instead of -L, some systems don't support -L

SVN-Revision: 8000
---

diff --git a/include/scan.mk b/include/scan.mk
index a0ee1ad678..04add4016c 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -31,7 +31,7 @@ endef
 
 $(FILELIST):
 	rm -f tmp/info/.files-$(SCAN_TARGET)-*
-	find -L $(SCAN_DIR) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call (Build/DefaultTargets|KernelPackage|Build(Package|Kernel))' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq > $@
+	find -follow $(SCAN_DIR) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call (Build/DefaultTargets|KernelPackage|Build(Package|Kernel))' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq > $@
 
 tmp/info/.files-$(SCAN_TARGET).mk: $(FILELIST)
 	( \