From: Jo-Philipp Wich <jo@mein.io>
Date: Thu, 5 Jan 2017 13:10:31 +0000 (+0100)
Subject: build: fix HOST_CONFIGURE_VARS placement
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=28f9df62f513c073b790b2d4c78a72649adce6ef;p=openwrt%2Fstaging%2Fldir.git

build: fix HOST_CONFIGURE_VARS placement

Ensure that HOST_CONFIGURE_VARS are set before the actual configure command
instead of passing them as configure command arguments.

This change brings host-build.mk in line with package-defaults.mk and makes
host configure environment variables work as expected.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---

diff --git a/include/host-build.mk b/include/host-build.mk
index b2f017bee2..f2109851d9 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -80,9 +80,9 @@ define Host/Configure/Default
 	$(if $(HOST_CONFIGURE_PARALLEL),+)(cd $(HOST_BUILD_DIR)/$(3); \
 		if [ -x configure ]; then \
 			$(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/$(3)/ && \
+			$(HOST_CONFIGURE_VARS) \
 			$(2) \
 			$(HOST_CONFIGURE_CMD) \
-			$(HOST_CONFIGURE_VARS) \
 			$(HOST_CONFIGURE_ARGS) \
 			$(1); \
 		fi \