From: Luka Perkov <luka@openwrt.org>
Date: Fri, 23 May 2014 09:35:27 +0000 (+0000)
Subject: kernel: other.mk: add pps-gpio support
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=295130a69b038223b1c59d8389e83e6524b45106;p=openwrt%2Fstaging%2Fynezz.git

kernel: other.mk: add pps-gpio support

The pps-gpio kernel module supports Pulse-Per-Second provided by a GPIO.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>

SVN-Revision: 40831
---

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 00c73fc920..8f68bd8251 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -775,6 +775,24 @@ endef
 $(eval $(call KernelPackage,pps))
 
 
+define KernelPackage/pps-gpio
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=PPS client using GPIO
+  DEPENDS:=+kmod-pps
+  KCONFIG:=CONFIG_PPS_CLIENT_GPIO
+  FILES:=$(LINUX_DIR)/drivers/pps/clients/pps-gpio.ko
+  AUTOLOAD:=$(call AutoLoad,18,pps-gpio,1)
+endef
+
+define KernelPacakge/pps-gpio/description
+ Support for a PPS source using GPIO. To be useful you must
+ also register a platform device specifying the GPIO pin and
+ other options, usually in your board setup.
+endef
+
+$(eval $(call KernelPackage,pps-gpio))
+
+
 define KernelPackage/ptp
   SUBMENU:=$(OTHER_MENU)
   TITLE:=PTP clock support