From: Andre Heider <a.heider@gmail.com>
Date: Sat, 18 Dec 2021 10:59:47 +0000 (+0100)
Subject: ltq-ifxos: enable for ipq40xx
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=2a0aa9eefadb3bad415eae84e023af70c06b020c;p=openwrt%2Fstaging%2Fnbd.git

ltq-ifxos: enable for ipq40xx

This is required for the MEI CPE driver.

Signed-off-by: Andre Heider <a.heider@gmail.com>
---

diff --git a/package/kernel/lantiq/ltq-ifxos/Makefile b/package/kernel/lantiq/ltq-ifxos/Makefile
index bc586faaf1..e8f41665dd 100644
--- a/package/kernel/lantiq/ltq-ifxos/Makefile
+++ b/package/kernel/lantiq/ltq-ifxos/Makefile
@@ -32,7 +32,7 @@ define KernelPackage/ltq-ifxos
   SUBMENU:=Libraries
   TITLE:=Lantiq OS abstraction library
   URL:=http://www.lantiq.com/
-  DEPENDS:=@TARGET_lantiq
+  DEPENDS:=@(TARGET_lantiq||TARGET_ipq40xx)
   FILES:=$(PKG_BUILD_DIR)/src/drv_ifxos.ko
   AUTOLOAD:=$(call AutoLoad,10,drv_ifxos)
 endef
@@ -44,13 +44,11 @@ CONFIGURE_ARGS += \
 	--enable-kernelincl="$(LINUX_DIR)/include" \
 	--with-kernel-module
 
-ifdef CONFIG_TARGET_lantiq
-  define Build/InstallDev
+define Build/InstallDev
 	$(INSTALL_DIR) $(1)/usr/{lib,include/ifxos}
 	$(CP) $(PKG_BUILD_DIR)/src/include/* $(1)/usr/include/ifxos
 	mkdir -p $(1)/usr/lib
 	$(CP) $(PKG_BUILD_DIR)/src/.libs/libifxos.a $(1)/usr/lib/libifxos.a
-  endef
-endif
+endef
 
 $(eval $(call KernelPackage,ltq-ifxos))