From: Jo-Philipp Wich <jow@openwrt.org>
Date: Wed, 31 Jul 2013 14:10:34 +0000 (+0000)
Subject: base-files: abort sysupgrade if file specified with --restore-config is not found
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=2a1ccf1830ee489212e3696995ea72471ab59200;p=openwrt%2Fstaging%2Fansuel.git

base-files: abort sysupgrade if file specified with --restore-config is not found

SVN-Revision: 37624
---

diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index dcae920f9a..93941b9155 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=144
+PKG_RELEASE:=145
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/sbin/sysupgrade b/package/base-files/files/sbin/sysupgrade
index 49c34b8073..f6b628e96e 100755
--- a/package/base-files/files/sbin/sysupgrade
+++ b/package/base-files/files/sbin/sysupgrade
@@ -140,7 +140,12 @@ if [ -n "$CONF_BACKUP" ]; then
 	exit $?
 fi
 
-if [ -f "$CONF_RESTORE" ] || [ "$CONF_RESTORE" = "-" ]; then
+if [ -n "$CONF_RESTORE" ]; then
+	if [ "$CONF_RESTORE" != "-" ] && [ ! -f "$CONF_RESTORE" ]; then
+		echo "Backup archive '$CONF_RESTORE' not found."
+		exit 1
+	fi
+
 	[ "$VERBOSE" -gt 1 ] && TAR_V="v" || TAR_V=""
 	tar -C / -x${TAR_V}zf "$CONF_RESTORE"
 	exit $?