From: Steven Barth <cyrus@openwrt.org>
Date: Wed, 26 Mar 2014 09:48:20 +0000 (+0000)
Subject: dhcp: send 6rd-ORO when expecting 6rd-information
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=2a893c205727686089887358498248ea21a91106;p=openwrt%2Fstaging%2Fsvanheule.git

dhcp: send 6rd-ORO when expecting 6rd-information

SVN-Revision: 40019
---

diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index 75314f161d..8414ff91b4 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netifd
-PKG_VERSION:=2014-03-21
+PKG_VERSION:=2014-03-26
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
diff --git a/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh b/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
index 0481d05132..80c3562e69 100755
--- a/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
+++ b/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
@@ -36,6 +36,7 @@ proto_dhcp_setup() {
 	[ "$broadcast" = 1 ] && broadcast="-B" || broadcast=
 	[ -n "$clientid" ] && clientid="-x 0x3d:${clientid//:/}" || clientid="-C"
 	[ -n "$iface6rd" ] && proto_export "IFACE6RD=$iface6rd"
+	[ -n "$iface6rd" ] && append dhcpopts "-O 212"
 	[ "$delegate" = "0" ] && proto_export "IFACE6RD_DELEGATE=0"
 
 	proto_export "INTERFACE=$config"