From: Felix Fietkau <nbd@openwrt.org>
Date: Wed, 16 Mar 2011 18:04:54 +0000 (+0000)
Subject: mpc85xx: copy the fdt for mpc8548cds to $(BIN_DIR)
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=2b6a84a7a388a5059657d44253a27f92f3322488;p=openwrt%2Fstaging%2Faparcar.git

mpc85xx: copy the fdt for mpc8548cds to $(BIN_DIR)

SVN-Revision: 26191
---

diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index bb9904572c..a5d1acbd5c 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -7,12 +7,15 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+DTS_TARGETS = mpc8548cds
+
 define Image/Prepare
 	cp $(LINUX_DIR)/arch/powerpc/boot/zImage $(KDIR)/zImage
 endef
 
 define Image/BuildKernel
 	cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+	$(foreach dts,$(DTS_TARGETS),$(LINUX_DIR)/scripts/dtc/dtc -I dts -O dtb $(LINUX_DIR)/arch/powerpc/boot/dts/$(dts).dts > $(BIN_DIR)/$(IMG_PREFIX)-$(dts).fdt)
 endef
 
 define Image/Build/ext2