From: John Crispin <john@openwrt.org>
Date: Thu, 29 Oct 2009 21:25:55 +0000 (+0000)
Subject: fixes bluetooth dependency, thx sn9
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=2bbb05cc5ea6e4ee6c9fce27b9ed8b082399193e;p=openwrt%2Fstaging%2Flinusw.git

fixes bluetooth dependency, thx sn9

SVN-Revision: 18213
---

diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 3d2985060d..28ba41469d 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -255,7 +255,7 @@ $(eval $(call KernelPackage,ssb))
 define KernelPackage/bluetooth
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Bluetooth support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-input-core
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-hid
   KCONFIG:= \
 	CONFIG_BLUEZ \
 	CONFIG_BLUEZ_L2CAP \