From: Rosen Penev <rosenp@gmail.com>
Date: Mon, 7 Feb 2022 04:51:40 +0000 (-0800)
Subject: tools/ccache: add cmake dependency
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=2d5f03205ab81fcbee6ef2d2853db98a85f0ecd3;p=openwrt%2Fstaging%2Fxback.git

tools/ccache: add cmake dependency

This will be needed for the next commit as ccache's cmake dependency is
satisfied by zstd currenly.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---

diff --git a/tools/Makefile b/tools/Makefile
index 681344a014..a13c2e82b5 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -87,7 +87,7 @@ endif
 ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
 $(foreach tool, $(filter-out xz zstd pkgconf patch ninja meson libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
 tools-y += ccache
-$(curdir)/ccache/compile := $(curdir)/zstd/compile
+$(curdir)/ccache/compile := $(curdir)/cmake/compile $(curdir)/zstd/compile
 endif
 
 # in case there is no patch tool on the host we need to make patch tool a