From: Felix Fietkau <nbd@openwrt.org>
Date: Tue, 13 Jun 2006 23:25:24 +0000 (+0000)
Subject: hopefully the last fix for the aruba image stuff
X-Git-Tag: kamikaze_7.06~1495^2~588
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=2d85d1932bcfaa205096e0307c95474036f7e649;p=openwrt%2Fsvn-archive%2Fopenwrt.git

hopefully the last fix for the aruba image stuff

SVN-Revision: 3942
---

diff --git a/openwrt/target/linux/image/aruba/Makefile b/openwrt/target/linux/image/aruba/Makefile
index d68084b261..c8dab056a0 100644
--- a/openwrt/target/linux/image/aruba/Makefile
+++ b/openwrt/target/linux/image/aruba/Makefile
@@ -23,13 +23,15 @@ define Image/BuildKernel
 	./addVersion -n ArubaOS $(KDIR)/loader.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari version
 endef
 
-ifeq ($(1),jffs2-64k)
-define Image/Build
+define Image/Build/jffs2-64k
 	@dd if=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari of=$(KDIR)/image.tmp bs=655360 conv=sync
 	@cat $(KDIR)/root.$(1) >> $(KDIR)/image.tmp
 	@dd if=$(KDIR)/image.tmp of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(patsubst jffs2-%,jffs2,$(1)).bin bs=3604480 conv=sync
 	@rm -f $(KDIR)/image.tmp
 endef
-endif
+
+define Image/Build
+	$(call Image/Build/$(1),$(1))
+endef
 
 $(eval $(call BuildImage))