From: Jo-Philipp Wich <jow@openwrt.org>
Date: Thu, 16 Feb 2012 17:58:33 +0000 (+0000)
Subject: [package] iwinfo: fix detection of Bullet M5, the PCI ID was wrong
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=2eaac41ebab4af2328dbe2253a6cc0fb4bcf774d;p=openwrt%2Fsvn-archive%2Farchive.git

[package] iwinfo: fix detection of Bullet M5, the PCI ID was wrong


SVN-Revision: 30591
---

diff --git a/package/iwinfo/Makefile b/package/iwinfo/Makefile
index 4f6bc1d363..27caf9fcba 100644
--- a/package/iwinfo/Makefile
+++ b/package/iwinfo/Makefile
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiwinfo
-PKG_RELEASE:=24
+PKG_RELEASE:=25
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
diff --git a/package/iwinfo/src/iwinfo_lib.c b/package/iwinfo/src/iwinfo_lib.c
index e33c795078..0e919861ca 100644
--- a/package/iwinfo/src/iwinfo_lib.c
+++ b/package/iwinfo/src/iwinfo_lib.c
@@ -351,7 +351,7 @@ const struct iwinfo_hardware_entry IWINFO_HARDWARE_ENTRIES[] = {
 	{ VENDOR_UBNT, "NanoStation M2",        0x168c, 0x002a, 0x0777, 0xe012, 10,     0 }, /* ToDo: confirm offset */
 	{ VENDOR_UBNT, "NanoStation M5",        0x168c, 0x002a, 0x0777, 0xe005,  5,     0 }, /* ToDo: confirm offset */
 	{ VENDOR_UBNT, "Bullet M2",             0x168c, 0x002a, 0x0777, 0xe202, 12,     0 },
-	{ VENDOR_UBNT, "Bullet M5",             0x168c, 0x002a, 0x0777, 0xe205,  5,     0 },
+	{ VENDOR_UBNT, "Bullet M5",             0x168c, 0x002a, 0x0777, 0xe805,  5,     0 },
 
 	{ VENDOR_ATH,  "AR9220",                0x168c, 0x0029, 0x168c, 0xa094,  0,     0 },
 	{ VENDOR_ATH,  "AR9223",                0x168c, 0x0029, 0x168c, 0xa095,  0,     0 },