From: John Crispin <john@openwrt.org>
Date: Tue, 26 Apr 2016 11:43:18 +0000 (+0000)
Subject: lantiq: build sysupgrade images for lantiqImage
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=2ef2a6aaf64118733b37d54052edad1b442cd24a;p=openwrt%2Fstaging%2Fjow.git

lantiq: build sysupgrade images for lantiqImage

Tested with VGV7510KW22NOR.

Signed-off-by: Mathias Kresin <openwrt@kresin.me>

SVN-Revision: 49238
---

diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 4a358b5123..d78c035ecd 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -301,6 +301,8 @@ define Device/Default
   FILESYSTEMS := squashfs
   DEVICE_PROFILE :=
   DEVICE_DTS :=
+  IMAGES := sysupgrade.bin
+  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs
 endef
 DEVICE_VARS += BOARD_ID DEVICE_PROFILE DEVICE_DTS