From: Alex Maclean <monkeh@monkeh.net>
Date: Wed, 20 Jun 2018 13:56:21 +0000 (+0100)
Subject: ramips: RE350: add rootfs offset to header
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=2f23a0583a3092d9076ceecca16be0f8ccdce217;p=openwrt%2Fstaging%2Fansuel.git

ramips: RE350: add rootfs offset to header

Have mktplinkfw fill in the rootfs offset so the firmware splitter can
find it without aligning to erase blocks.

Signed-off-by: Alex Maclean <monkeh@monkeh.net>
---

diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index e9e2d3ecef..778f3d6bf8 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -256,7 +256,7 @@ define Device/re350-v1
   TPLINK_HWREV := 0
   TPLINK_HEADER_VERSION := 1
   IMAGE_SIZE := 6016k
-  KERNEL := $(KERNEL_DTB) | tplink-v1-header -e
+  KERNEL := $(KERNEL_DTB) | tplink-v1-header -e -O
   IMAGES := sysupgrade.bin factory.bin
   IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | append-metadata | check-size $$$$(IMAGE_SIZE)
   IMAGE/factory.bin := append-rootfs | tplink-safeloader factory