From: Felix Fietkau <nbd@nbd.name>
Date: Wed, 28 Dec 2016 00:10:37 +0000 (+0100)
Subject: libressl: disable shared libraries, fixes build issues
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=2fd5ce9488d11c7e6eee7dc30f128bd12be889f5;p=openwrt%2Fstaging%2Fldir.git

libressl: disable shared libraries, fixes build issues

Signed-off-by: Felix Fietkau <nbd@nbd.name>
---

diff --git a/tools/libressl/Makefile b/tools/libressl/Makefile
index 27f8496fdb..1e3a6f80fb 100644
--- a/tools/libressl/Makefile
+++ b/tools/libressl/Makefile
@@ -21,4 +21,6 @@ HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_CONFIGURE_ARGS += --disable-shared
+
 $(eval $(call HostBuild))