From: Felix Fietkau <nbd@openwrt.org>
Date: Thu, 14 Jun 2012 20:26:00 +0000 (+0000)
Subject: build: add a variable for injecting config variable dependencies for the .prepared... 
X-Git-Tag: reboot~13601
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=3051de8701b5c13e4df781c52950c68234b04ee4;p=openwrt%2Fstaging%2Fblogic.git

build: add a variable for injecting config variable dependencies for the .prepared stamp

SVN-Revision: 32368
---

diff --git a/include/package.mk b/include/package.mk
index 30dd3ec8286e..e955c207aeea 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -31,7 +31,7 @@ ifneq ($(PREV_STAMP_PREPARED),)
   STAMP_PREPARED:=$(PREV_STAMP_PREPARED)
   CONFIG_AUTOREBUILD:=
 else
-  STAMP_PREPARED=$(PKG_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,_$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPENDS),)))
+  STAMP_PREPARED=$(PKG_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,_$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPENDS),))$(call confvar,$(PKG_PREPARED_DEPENDS)))
 endif
 STAMP_CONFIGURED:=$(PKG_BUILD_DIR)/.configured$(if $(DUMP),,_$(call confvar,$(PKG_CONFIG_DEPENDS)))
 STAMP_CONFIGURED_WILDCARD=$(patsubst %_$(call confvar,$(PKG_CONFIG_DEPENDS)),%_*,$(STAMP_CONFIGURED))