From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 7 Feb 2011 18:17:12 +0000 (+0000)
Subject: add libubox, a small utility library containing blob/blobmsg (structured message... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=30a49a35ae1746ace8cc1e5c9bdcc7ccedbe297d;p=openwrt%2Fstaging%2Fjow.git

add libubox, a small utility library containing blob/blobmsg (structured message format libraries), uloop, usock, list.h and the olsr avl tree implementation

SVN-Revision: 25406
---

diff --git a/package/libubox/Makefile b/package/libubox/Makefile
new file mode 100644
index 0000000000..a2b3a9c51a
--- /dev/null
+++ b/package/libubox/Makefile
@@ -0,0 +1,41 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libubox
+PKG_VERSION:=2010-02-07
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://nbd.name/luci2/libubox.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=e44dbfb1029829dbd6c5e1ca11e461d9a89027b9
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+CMAKE_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/libubox
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Basic utility library
+  DEPENDS:=+libjson
+endef
+
+
+define Package/libblobmsg-json
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=blobmsg <-> json conversion library
+  DEPENDS:=+libjson
+endef
+
+
+TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+
+define Package/libubox/install
+	$(INSTALL_DIR) $(1)/lib/
+	$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/*.so $(1)/lib/
+endef
+
+$(eval $(call BuildPackage,libubox))
+