From: Florian Fainelli <florian@openwrt.org>
Date: Thu, 27 Mar 2008 18:24:13 +0000 (+0000)
Subject: layer7 filtering module is now xt_layer7 (#3268)
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=30f886203301dbed00315f5c996075d8d99ea87d;p=openwrt%2Fstaging%2Fwigyori.git

layer7 filtering module is now xt_layer7 (#3268)

SVN-Revision: 10674
---

diff --git a/include/netfilter.mk b/include/netfilter.mk
index 0a0e54af16..ee0dbf3a13 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -72,6 +72,7 @@ $(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_TARGET_REJECT, $(P_V4)ipt_REJECT))
 
 $(eval $(call nf_add,IPT_FILTER,CONFIG_IP_NF_MATCH_IPP2P, $(P_V4)ipt_ipp2p))
 $(eval $(call nf_add,IPT_FILTER,CONFIG_IP_NF_MATCH_LAYER7, $(P_V4)ipt_layer7))
+$(eval $(call nf_add,IPT_FILTER,CONFIG_NETFILTER_XT_MATCH_LAYER7, $(P_XT)xt_layer7))
 $(eval $(call nf_add,IPT_FILTER,CONFIG_IP_NF_MATCH_STRING, $(P_V4)ipt_string))
 $(eval $(call nf_add,IPT_FILTER,CONFIG_NETFILTER_XT_MATCH_STRING, $(P_XT)xt_string))