From: Felix Fietkau <nbd@nbd.name>
Date: Tue, 4 Apr 2017 13:05:11 +0000 (+0200)
Subject: busybox: fix installation of cron and ntpd scripts in the default config
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=3169a6a7ada17e2ea8ef4641edee68134c04b92b;p=openwrt%2Fstaging%2Fldir.git

busybox: fix installation of cron and ntpd scripts in the default config

Fixes: 0b24850e9778 ("busybox: don't install NTP scripts if NTP isn't configured")
Signed-off-by: Felix Fietkau <nbd@nbd.name>
---

diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 48d945718a..be4b967a47 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -112,10 +112,10 @@ endef
 define Package/busybox/install
 	$(INSTALL_DIR) $(1)/etc/init.d
 	$(CP) $(PKG_INSTALL_DIR)/* $(1)/
-ifneq ($(CONFIG_BUSYBOX_CONFIG_CROND),)
+ifneq ($(CONFIG_BUSYBOX_$(BUSYBOX_SYM)_CROND),)
 	$(INSTALL_BIN) ./files/cron $(1)/etc/init.d/cron
 endif
-ifneq ($(CONFIG_BUSYBOX_CONFIG_NTPD),)
+ifneq ($(CONFIG_BUSYBOX_$(BUSYBOX_SYM)_NTPD),)
 	$(INSTALL_BIN) ./files/sysntpd $(1)/etc/init.d/sysntpd
 	$(INSTALL_BIN) ./files/ntpd-hotplug $(1)/usr/sbin/ntpd-hotplug
 endif