From: Andy Boyett <agb@openwrt.org>
Date: Mon, 5 Oct 2009 17:05:43 +0000 (+0000)
Subject: modules/crypto: package AMCC ppc4xx hardware crypto driver
X-Git-Tag: reboot~22274
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=333be1a4d766901a3808e110655c5108cc067439;p=openwrt%2Fstaging%2Fblogic.git

modules/crypto: package AMCC ppc4xx hardware crypto driver

SVN-Revision: 17906
---

diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index e2361a26c0c1..f75ebe9f81ea 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -139,6 +139,25 @@ endef
 $(eval $(call KernelPackage,crypto-hw-ixp4xx))
 
 
+define KernelPackage/crypto-hw-ppc4xx
+  SUBMENU:=$(CRYPTO_MENU)
+  TITLE:=AMCC PPC4xx hardware crypto module
+  DEPENDS:= \
+	@TARGET_ppc40x||TARGET_ppc44x +kmod-crypto-core
+  KCONFIG:= \
+	CONFIG_CRYPTO_HW=y \
+	CONFIG_CRYPTO_DEV_PPC4XX
+  FILES:=$(LINUX_DIR)/drivers/crypto/amcc/crypto4xx.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,90,crypto4xx)
+endef
+
+define KernelPackage/crypto-hw-ppc4xx/description
+  Kernel support for the AMCC PPC4xx HW crypto engine.
+endef
+
+$(eval $(call KernelPackage,crypto-hw-ppc4xx))
+
+
 define KernelPackage/crypto-aes
   SUBMENU:=$(CRYPTO_MENU)
   TITLE:=AES cipher CryptoAPI module