From: Jonas Gorski <jonas.gorski@gmail.com>
Date: Sun, 18 Jun 2017 15:40:01 +0000 (+0200)
Subject: kernel: do not try to probe builtin modules on empty kmod package install
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=34c01e68b5d6b06ce3794ef0e2b06e81ec3ce8ca;p=openwrt%2Fstaging%2Fldir.git

kernel: do not try to probe builtin modules on empty kmod package install

Builtin modules are always present, and trying to load them will cause
modprobe to spew errors when installing the empty kmod packages.

Fix this by never generating any postinst module install instructions
for builtin modules.

Fixes #842.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
---

diff --git a/include/kernel.mk b/include/kernel.mk
index 7674f0dadc..d780ef0ce2 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -136,6 +136,7 @@ define ModuleAutoLoad
 		local mod; \
 		shift 2; \
 		for mod in $$$$$$$$mods; do \
+			[ -e $(2)/$(MODULES_SUBDIR)/$$$$$$$$mod.ko ] || continue; \
 			mkdir -p $(2)/etc/modules.d; \
 			echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$(1); \
 		done; \
@@ -154,6 +155,7 @@ define ModuleAutoLoad
 		local mod; \
 		shift 3; \
 		for mod in $$$$$$$$mods; do \
+			[ -e $(2)/$(MODULES_SUBDIR)/$$$$$$$$mod.ko ] || continue; \
 			mkdir -p $(2)/etc/modules.d; \
 			echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$$$$$$$$priority-$(1); \
 		done; \