From: Tiago Gaspar <tiagogaspar8@gmail.com>
Date: Sun, 2 Jul 2023 17:14:10 +0000 (+0100)
Subject: nginx: add quic modue
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=34e73bddab3dc22d0f2d9efc634f947e0232a51c;p=feed%2Fpackages.git

nginx: add quic modue

This commit  adds support for http/3. This is an experimental version
and isn't fully supported because nginx is being built with the regular
OpenSSL and the regular one doesn't support quic.

Signed-off-by: Tiago Gaspar <tiagogaspar8@gmail.com>
---

diff --git a/net/nginx/Config_ssl.in b/net/nginx/Config_ssl.in
index fbfb64ae72..990a01e813 100644
--- a/net/nginx/Config_ssl.in
+++ b/net/nginx/Config_ssl.in
@@ -175,6 +175,11 @@ config NGINX_HTTP_V2
 	prompt "Enable HTTP_V2 module"
 	default y
 
+config NGINX_HTTP_QUIC
+	bool
+	prompt "Enable QUIC support"
+	default n
+
 config NGINX_PCRE
 	bool
 	prompt "Enable PCRE library usage"
diff --git a/net/nginx/Makefile b/net/nginx/Makefile
index b90f55d0aa..5c162a3bcd 100644
--- a/net/nginx/Makefile
+++ b/net/nginx/Makefile
@@ -76,6 +76,7 @@ PKG_CONFIG_DEPENDS := \
 	CONFIG_NGINX_HTTP_UPSTREAM_ZONE \
 	CONFIG_NGINX_HTTP_CACHE \
 	CONFIG_NGINX_HTTP_V2 \
+	CONFIG_NGINX_HTTP_QUIC \
 	CONFIG_NGINX_PCRE \
 	CONFIG_NGINX_HTTP_REAL_IP \
 	CONFIG_NGINX_HTTP_SECURE_LINK \
@@ -401,6 +402,7 @@ CONFIGURE_ARGS += \
 	$(if $(call IsEnabled,NGINX_FLV),--with-http_flv_module) \
 	$(if $(call IsEnabled,NGINX_DAV),--with-http_dav_module) \
 	$(if $(call IsEnabled,NGINX_HTTP_AUTH_REQUEST),--with-http_auth_request_module) \
+	$(if $(call IsEnabled,NGINX_HTTP_QUIC),--with-http_v3_module) \
 	$(if $(call IsEnabled,NGINX_HTTP_V2),--with-http_v2_module) \
 	$(if $(call IsEnabled,NGINX_HTTP_REAL_IP),--with-http_realip_module) \
 	$(if $(call IsEnabled,NGINX_HTTP_SECURE_LINK),--with-http_secure_link_module) \