From: Jo-Philipp Wich <jo@mein.io>
Date: Wed, 3 Jan 2018 12:13:10 +0000 (+0100)
Subject: kernel: fix packaging of kmod-gpio-nxp-74hc164
X-Git-Tag: v18.06.0-rc1~1406
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=34e9937f2afdf512506836e27cbc4a720049453f;p=openwrt%2Fstaging%2Fpepe2k.git

kernel: fix packaging of kmod-gpio-nxp-74hc164

The NXP 74HC164 GPIO expander driver uses a different config symbol
("CONFIG_GPIO_74X164") and module name since since at least Kernel
version 2.6.37.

Update the kmod package definition accordingly by adjusting kconfig
and module file names.

This unrelated, but correct change has been separated from the
WNR2000v5 support commits.

Ref: https://github.com/lede-project/source/pull/1256
Suggested-by: Raphael Catolino <raphael.catolino@gmail.com>
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 1c7869e7c6..973e4f3e26 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -242,9 +242,9 @@ $(eval $(call KernelPackage,gpio-mcp23s08))
 define KernelPackage/gpio-nxp-74hc164
   SUBMENU:=$(OTHER_MENU)
   TITLE:=NXP 74HC164 GPIO expander support
-  KCONFIG:=CONFIG_GPIO_NXP_74HC164
-  FILES:=$(LINUX_DIR)/drivers/gpio/nxp_74hc164.ko
-  AUTOLOAD:=$(call AutoProbe,nxp_74hc164)
+  KCONFIG:=CONFIG_GPIO_74X164
+  FILES:=$(LINUX_DIR)/drivers/gpio/gpio-74x164.ko
+  AUTOLOAD:=$(call AutoProbe,gpio-74x164)
 endef
 
 define KernelPackage/gpio-nxp-74hc164/description