From: Amol Bhave <ambhave@fb.com>
Date: Mon, 24 Sep 2018 17:39:19 +0000 (-0700)
Subject: build: use CMAKE_SOURCE_SUBDIR variable to cmake.mk
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=366e6ef5c342f5926d9ab07166b8a40734393dc2;p=openwrt%2Fstaging%2Fansuel.git

build: use CMAKE_SOURCE_SUBDIR variable to cmake.mk

Sometimes, the CMakeLists.txt file is not in the root directory of a
repo. In those cases, the CMAKE_SOURCE_SUBDIR variable can be specified
to use CMakeLists.txt from a subdirectory instead.

Signed-off-by: Amol Bhave <ambhave@fb.com>
---

diff --git a/include/cmake.mk b/include/cmake.mk
index 900dae1d4a..b66665d20a 100644
--- a/include/cmake.mk
+++ b/include/cmake.mk
@@ -7,8 +7,8 @@ ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
 endif
 
 CMAKE_BINARY_DIR = $(PKG_BUILD_DIR)$(if $(CMAKE_BINARY_SUBDIR),/$(CMAKE_BINARY_SUBDIR))
-CMAKE_SOURCE_DIR = $(PKG_BUILD_DIR)
-HOST_CMAKE_SOURCE_DIR = $(HOST_BUILD_DIR)
+CMAKE_SOURCE_DIR = $(PKG_BUILD_DIR)$(if $(CMAKE_SOURCE_SUBDIR),/$(CMAKE_SOURCE_SUBDIR))
+HOST_CMAKE_SOURCE_DIR = $(HOST_BUILD_DIR)$(if $(CMAKE_SOURCE_SUBDIR),/$(CMAKE_SOURCE_SUBDIR))
 MAKE_PATH = $(firstword $(CMAKE_BINARY_SUBDIR) .)
 
 ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)