From: Mathias Kresin <dev@kresin.me>
Date: Mon, 6 Aug 2018 15:47:41 +0000 (+0200)
Subject: ath79: mark netgear variables as device specific
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=38877d88731037a5708051b0ecaad7da82ca1c84;p=openwrt%2Fstaging%2Fansuel.git

ath79: mark netgear variables as device specific

The variables are used in image build recipes and need to be marked as
per devices vars to be stored individual per image define. Otherwise
the last defined variable will be used for all boards.

Signed-off-by: Mathias Kresin <dev@kresin.me>
---

diff --git a/target/linux/ath79/image/common-netgear.mk b/target/linux/ath79/image/common-netgear.mk
index ca4e005689..5dfcd38a92 100644
--- a/target/linux/ath79/image/common-netgear.mk
+++ b/target/linux/ath79/image/common-netgear.mk
@@ -1,3 +1,5 @@
+DEVICE_VARS += NETGEAR_KERNEL_MAGIC NETGEAR_BOARD_ID NETGEAR_HW_ID
+
 define Build/netgear-squashfs
 	rm -rf $@.fs $@.squashfs
 	mkdir -p $@.fs/image