From: John Crispin <john@openwrt.org>
Date: Mon, 2 Jun 2014 12:44:13 +0000 (+0000)
Subject: package/Makefile: Substituted deprecated -perm +mode with -perm /mode
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=3936ed402896c4e35ba9a84cc31f92feecb0a139;p=openwrt%2Fstaging%2Fstintel.git

package/Makefile: Substituted deprecated -perm +mode with -perm /mode

The find(1) -perm +mode is no longer supported and has been deprecated since
2005.

This could resolve #13855 ticket.

Signed-off-by: Rocco Folino <lordzen87@gmail.com>

SVN-Revision: 40927
---

diff --git a/package/Makefile b/package/Makefile
index e189e37043..1930d27cf8 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -26,7 +26,7 @@ ifdef CONFIG_USE_MKLIBS
   define mklibs
 	rm -rf $(TMP_DIR)/mklibs-progs $(TMP_DIR)/mklibs-out
 	# first find all programs and add them to the mklibs list
-	find $(STAGING_DIR_ROOT) -type f -perm +100 -exec \
+	find $(STAGING_DIR_ROOT) -type f -perm /100 -exec \
 		file -r -N -F '' {} + | \
 		awk ' /executable.*dynamically/ { print $$1 }' > $(TMP_DIR)/mklibs-progs
 	# find all loadable objects that are not regular libraries and add them to the list as well