From: Florian Fainelli <florian@openwrt.org>
Date: Sat, 10 Jan 2015 20:11:18 +0000 (+0000)
Subject: mcs814x: account for dtb output directory differences
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=3b523f6780113b0f55a2362ab093145dfa2a7c75;p=openwrt%2Fstaging%2Fwigyori.git

mcs814x: account for dtb output directory differences

3.3 produced *.dtb files in arch/arm/boot/ while 3.14 will produce those
in arch/arm/boot/dts/, adjust the image makefile accordingly.

Signed-off-by: Florian Fainelli <florian@openwrt.org>

SVN-Revision: 43925
---

diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 1c814fa4fd..7f8722d6bd 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -9,6 +9,12 @@ include $(INCLUDE_DIR)/image.mk
 
 TARGET_DTBS := rbt-832 dlan-usb-extender
 
+ifeq ($(KERNEL_PATCHVER),3.3)
+DTBS_DIR:=
+else
+DTBS_DIR:=dts/
+endif
+
 LOADADDR:=0x00008000
 
 JFFS2_BLOCKSIZE = 128k
@@ -22,7 +28,7 @@ endef
 
 define Image/Build/DTB
 	cp $(KDIR)/zImage$(2) $(KDIR)/zImage-$(1);
-	cat $(LINUX_DIR)/arch/$(ARCH)/boot/$(1).dtb >> $(KDIR)/zImage$(2)-$(1);
+	cat $(LINUX_DIR)/arch/$(ARCH)/boot/$(DTBS_DIR)$(1).dtb >> $(KDIR)/zImage$(2)-$(1);
 	$(call Image/Build/MkuImage,$(KDIR)/zImage$(2)-$(1),$(KDIR)/uImage$(2)-$(1))
 	cp $(KDIR)/uImage$(2)-$(1) $(UIMAGE)$(2)-$(1);
 endef