From: Jo-Philipp Wich <jow@openwrt.org>
Date: Wed, 13 Jun 2012 11:42:17 +0000 (+0000)
Subject: package-ipkg.sh: copy the package provides list for all virtual PROVIDES
X-Git-Tag: reboot~13610
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=3b65557db8d43ad0071149c2f16d6ed1b927e801;p=openwrt%2Fstaging%2Fblogic.git

package-ipkg.sh: copy the package provides list for all virtual PROVIDES

SVN-Revision: 32332
---

diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index e9bac7a23be9..7ff3f6e23aaf 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -144,6 +144,7 @@ ifeq ($(DUMP),)
 			fi; \
 		done; \
 	) | sort -u > $(PKG_INFO_DIR)/$(1).provides
+	$(if $(PROVIDES),@for pkg in $(PROVIDES); do cp $(PKG_INFO_DIR)/$(1).provides $(PKG_INFO_DIR)/$$pkg.provides; done)
 	$(CheckDependencies)
 
 	$(RSTRIP) $$(IDIR_$(1))