From: John Crispin <john@openwrt.org>
Date: Mon, 15 Jul 2013 11:08:04 +0000 (+0000)
Subject: kernel: add usb-dwc2 kmod
X-Git-Tag: reboot~9883
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=3cfa187818d57954bb2721d0e73311846215df3c;p=openwrt%2Fstaging%2Fpepe2k.git

kernel: add usb-dwc2 kmod

Signed-off-by: John Crispin <blogic@openwrt.org>

SVN-Revision: 37338
---

diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 1cb8e2c1b2..0fa99ccb79 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -172,6 +172,29 @@ endef
 $(eval $(call KernelPackage,usb2-pci))
 
 
+define KernelPackage/usb-dwc2
+  TITLE:=DWC2 USB controller driver
+  DEPENDS:=@LINUX_3_10
+  KCONFIG:= \
+	CONFIG_USB_DWC2 \
+	CONFIG_USB_DWC2_DEBUG=n \
+	CONFIG_USB_DWC2_VERBOSE=n \
+	CONFIG_USB_DWC2_TRACK_MISSED_SOFS=n
+  FILES:= \
+	$(LINUX_DIR)/drivers/staging/dwc2/dwc2.ko \
+	$(LINUX_DIR)/drivers/staging/dwc2/dwc2_platform.ko
+  AUTOLOAD:=$(call AutoLoad,54,dwc2 dwc2_platform,1)
+  $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-dwc2/description
+  This driver provides USB Device Controller support for the
+  Synopsys DesignWare USB OTG Core.
+endef
+
+$(eval $(call KernelPackage,usb-dwc2))
+
+
 define KernelPackage/usb-acm
   TITLE:=Support for modems/isdn controllers
   KCONFIG:=CONFIG_USB_ACM