From: Ralph Hempel <ralph.hempel@lantiq.com>
Date: Fri, 20 Feb 2009 10:32:45 +0000 (+0000)
Subject: avoid kernel version in target if sub-targets available (usefull if we have 2.4 and... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=3d0285a783851da63b0e17ad251ee2add9322408;p=openwrt%2Fstaging%2Fdangole.git

avoid kernel version in target if sub-targets available (usefull if we have 2.4 and 2.6 sub-targets in parallel)

SVN-Revision: 14576
---

diff --git a/include/target.mk b/include/target.mk
index 7351794dce..ee373aa19e 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -154,7 +154,7 @@ define BuildTargets/DumpCurrent
 	@echo 'Target: $(TARGETID)'; \
 	 echo 'Target-Board: $(BOARD)'; \
 	 echo 'Target-Kernel: $(KERNEL)'; \
-	 echo 'Target-Name: $(BOARDNAME)$(if $(SUBTARGET),, [$(KERNEL)])'; \
+	 echo 'Target-Name: $(BOARDNAME)$(if $(SUBTARGETS),, [$(KERNEL)])$(if $(SUBTARGETS),$(if $(SUBTARGET), [$(KERNEL)]))'; \
 	 echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'; \
 	 echo 'Target-Arch: $(ARCH)'; \
 	 echo 'Target-Features: $(FEATURES)'; \